法政大学市ヶ谷基礎科目

情報処理演習I

担当 重定 如彦

200372

 

10回 ワードプロセッサ (Word Processor)

1.      ワードプロセッサとテキストエディタ

文字を編集するためのソフトは「テキストエディタ」と「ワードプロセッサ」の2つに分類することができます。ウィンドウズのテキストエディタにはメモ帳やEmEditorが挙げられます。テキストエディタは文字しか扱えず、機能もそれほど多くはありませんが、余分な機能がついていない分だけ動作が軽快です。例えば、テキストエディタは文字の大きさや色を変えることはできませんが、そのような文字修飾を必要としない文章や、修飾情報が却って邪魔になってしまうコンピュータプログラムを作成する場合に使用されます。

一方、ワードプロセッサ(ワープロ)は主に印刷を目的とするような文章を作る時に使われます。ワープロでは文字に対して大きさやフォントや色など様々な修飾を行ったり、文章の中に表や画像を埋め込むことが可能です。また、ワープロはただ単に文章を入力するためのソフトではありません。ワープロを使って頭で考えたアイディアを書いて行き、試行錯誤しながらまとめていくことができます。手書きの文章では一旦文章を書いてしまうと新しく文章を追加したり、レイアウトを変更することは非常に困難でしたが、ワープロでは好きな場所にいつでも文章を追加することができるため、文章のレイアウトを後から変更することは非常に簡単です。また、ワープロには文章の作成を助けてくれるための様々な機能がついています。例えば辞書機能を使えば自動的に英語や日本語の文法やスペルチェックを行ってくれますし、「検索・置換」機能を使えば文章内の間違った部分を簡単な操作で訂正することが可能です。このように、ワープロの出現によって、これまで紙の文章で書く際に気をつけなければなかった様々な事をコンピュータが代わりに行ってくれるようになり、文章の内容に対する気配りに集中することができるようになりました。

〜参考:文字の修飾の仕組み〜 

テキストエディタで作られた文章データは、コンピュータの中ではエディタの画面に表示されている文字がそのまま並んだ形で扱われますが、ワープロで作られたデータは実は画面に表示された文字以外の情報を含んでいます。例えばワープロで  
   あ

のような修飾つきの文章を記述するとワープロの内部では次のようなデータが作られます。

 (通常のサイズの文字)あ(大きな文字)い(太字)う(斜体)え(下線)お  

この中で()の中に書かれている部分は、文字を修飾する為の情報です。これらの情報はワープロの画面には表示されませんが、文章データの中に埋め込まれており、それらの情報を元にワープロソフトは文字に修飾を施して画面に表示を行っています。同じ文章をテキストエディタで作成した時とワープロで作成した時のファイルのサイズを比較するとワープロのほうがサイズが大きくなるのはこのような修飾データが入っているからです。

2.      Wordの基本的な使い方

ウィンドウズ上のワープロソフトには様々なものがありますが、授業ではマイクロソフト社のWordの使い方を説明します。Wordに限ったことではありませんが、最近のワープロにはとにかく多くの機能がついています。しかしその中で実際に頻繁に使われる機能はそれほど多くありません。実際Wordの機能をすべて理解している人はほとんどいないといって良いでしょう。授業ではWordの機能のうち良く使われる基本的な機能について解説します。それ以外の機能については、ヘルプやWordの解説書などを見て各自勉強して下さい。

·          Wordの起動

Wordを起動するにはスタートメニューのプログラムの中からMicrosoft Wordを選択するか、Iconフォルダ内のMicrosoft Wordというアイコンをダブルクリックして下さい。

簡易ヘルプ機能

 
Wordの画面構成は以下のようになっています。

ステータスバー

 

ツールバー

 

メニューバー

 

·          メニューバーとツールバー

Wordで使用される機能のほぼすべては、メニューから呼び出すことができます。しかし、メニュー操作は手間がかかりますし、かといってワープロのように機能が多いソフトはショートカット操作を覚えるのが大変です。そこで、メニューの下にワープロの機能をボタンの形で表示するツールバーが用意されています。ツールバーにはいくつか種類があり、どれを表示するかはメニューの「表示」「ツールバー」で設定することができます。ツールバーのうち「標準」と「書式設定」はよく使いますので、常に表示するようにすると良いでしょう(いずれも最初から表示されます)。

ツールバーはツールバーの左の部分をドラッグすることで移動したり、ウィンドウ化することができます。スペースの都合でツールバーの全てのボタンが表示しきれない場合は、ツールバーの右に >> ボタンが表示されます。このボタンをクリックすると、表示しきれなかったツールバーの残りのボタンがメニューで表示されます。

ツールバーは画面の下のステータスバーの上にも置くことができます。図では、ステータスバーの上に、「ファンクションキーの表示」というツールバーが表示されています。

この部分をドラッグして移動

 

残りの部分を表示するボタン

 
 

 


·          ステータスバーと簡易ヘルプ

 ウィンドウの一番下の部分はステータスバーと呼ばれる部分で、ここに現在編集中の文章の状態(ステータス)が表示されます。また、メニューバーの一番右には簡易ヘルプ機能のための入力フォームがあり、そこに知りたいことを入力してエンターキーを押すとヘルプが表示されるようになっています。なお、Wordにはもっと本格的なヘルプ機能が用意されており、そちらはメニューの「ヘルプ」から呼び出すことができます。

·          文字の修飾(書式設定バーの使い方)

 ワープロでは文字に対して様々な修飾を行うことができます。修飾を行うには修飾を行いたい部分の文字列を選択状態にし、書式設定バーのボタンをクリックします。

主な修飾には以下のようなものがあり、多くの修飾は組み合わせることができます。なお、日本語でよく使われるフォントはMS明朝、英語はTimes New Romanです。

(注:画面にはいりきらないので、下の図は書式設定バーを2つに分けています)

文字修飾

 

フォント

 

文字サイズ

 
 (左半分です)

ルビetc.

 

文字色

 

箇条書きとインデント

 

文字揃え

 
    (右半分です)

 

修飾

設定方法(ツールバー)

修飾例

フォント

フォント名を選んで指定

情報基礎 情報基礎

文字サイズ

フォントのサイズを選んで指定

情報基礎 情報基礎

文字修飾

(組み合わせ可能)

情報 基礎 情報 基礎

文字揃え

後述

箇条書きとインデント

後述

文字の色

 左が背景色、右が文字の色

プリントが白黒なので割愛

ルビetc.

 左からルビ、囲い文字、下付き

情報(じょうほう)  a

 練習:上の表の修飾例に記述されている文字(後述及び割愛と書かれているものは除く)を入力し表と同じ修飾を行って下さい。また、文字に色をつけて下さい。

·          文字揃え

文章を選択し、文字揃えのボタンを押すことで、文章を左そろえ、中央そろえ、右そろえ、均等揃えにすることができます。また一番右のボタンをクリックして表示されるメニューを使って行の間隔を設定することができます。

練習:以下の文章を入力して下さい。

これは左揃えの文章です。

これは中央揃えの文章です。

これは右揃えの文章です。

これは均等揃えの文章です。


·          段落、箇条書き、インデント

ツールバーの段落番号()の部分をクリックすると、段落を入力するモードになります。段落入力モードでは、改行をすると自動的に段落番号が以下のように挿入されます。

1.         第一段落

2.         第二段落

3.        

 

同様に、箇条書きボタン()をクリックすると箇条書きモードになり、改行を行うと以下のように自動的に行頭に箇条書きマークが挿入されるようになります。

·           箇条書きその1

·           箇条書きその2

·          

段落や箇条書きモードでは、該当するボタンのグラフィックが四角い枠で囲まれて表示されます。これらのモードを解除するにはもう一度「段落番号」や「箇条書き」のボタンを押して下さい。また、段落番号や箇条書きモードではエンターキーを押すと自動的に次の段落番号や箇条書きのマークが行頭に挿入されますが、シフトキーを押しながらエンターキーを押すことで、改行のみを行うことができます。

段落や箇条書きモードで、先頭に表示される記号を変更することができます。変更は行うには、マークが表示されている行にマウスカーソルを移動させ、マウスのメニューボタンをクリックし、「箇条書きと段落番号」を選択して表示されるパネルで行います。

インデントボタンをクリックすると、その行以降に入力する文章の行頭の位置が1文字分右にずれるようになります。また、インデント解除ボタンをクリックするとインデントが解除され1文字分左にずれるようになります。

·          段組

文章を選択し、メニューの「書式」「段組み」を選択することで、文章の段組を変えることができます。例えば2段組の文章は以下のようになります。


ワープロでは文字に対して様々な修飾を行うことができます。主な修飾には以下のようなものがあり、それぞれの修飾は組み合わせることができます。

日本語でよく使われるフォントはMS明朝、英語はTimes New Romanです。


·          標準ツールバーの使い方
主な標準ツールバーの使い方について表にします。

ボタン

意味

左からファイルメニューの「新規作成」、「開く」、「上書き保存」と同じ

印刷と印刷プレビュー(後述)を行う為のボタン

カット(コピー)アンドペーストを行う為のボタン

左は一つ前に行った操作を取り消すためのボタン。右は左の取り消しボタンで取り消した操作を元に戻す為のボタン。

ズームボタン。文章を拡大、縮小表示することができる。

ヘルプボタン。簡易ヘルプよりも本格的なヘルプ機能を呼び出す。

·          画面の表示設定

メニューの「表示」の一番上に表示される項目を選択することで、文章のレイアウトを変更することができます。通常は印刷した時のレイアウトで表示される「印刷レイアウト」を選択すると良いでしょう。また、印刷レイアウトの状態で、メニューの「表示」「グリッド線」を選択することで、罫線を表示することができます。なお、このグリッド線で表示される罫線は入力した文字がどこに配置されるかの目安であり、印刷時には印刷されない点に注意して下さい。ページの標準の文字フォントサイズや、上下左右の余白のサイズを設定するには、メニューの「ファイル」「ページ設定」を実行して表示されるパネルで設定します。ここで横書きと縦書きの設定を行うこともできます。

·          ページ番号と改ページ

文章にページ番号を入れるにはメニューの「挿入」「ページ番号」を選択します。

メニューの「挿入」「改ページ」を実行することで改ページを行うことができます。

·          ワードアート

文字修飾で説明した修飾よりももっと凝った修飾を行うことができます。これをワードアートと呼びます。ワードアートを行うには、メニューの「表示」「ツールバー」「ワードアート」を実行してワードアートのツールバー(下図)を表示します。

次にワードアートの挿入ボタン()を押して下さい。ワードアートの一覧が表示されるので、その中から使いたいワードアートを選択して、OKボタンを押します。文字を入力するためのパネルが表示されるので、文字を入力してOKボタンを押してください。

ワードアートの例

 

作ったワードアートを編集するには、編集したいワードアートを選択して、ワードアートのツールバーのボタンを押します。例えば文字を変更したい場合は「テキストの編集」ボタン、ワードアートの種類を変更したい場合はワードアートギャラリーボタン()、細かい設定を行いたい場合はワードアートの書式設定ボタン()をクリックします。様々な編集を行うことができるので、各自いろいろ試してみて下さい。

 

 

3.      Word文章の新規作成、保存、印刷

·          新規作成
Wordを使って新しい文章を新規作成するには以下の3つの方法があります。

Ø        デスクトップのMicrosoft Wordのアイコンをダブルクリックして起動

Ø        スタートメニューからMicrosoft Wordを選択して起動

Ø        Wordのメニューの「ファイル」「新規作成」を実行

このうち3番目の方法を行うと、ウィンドウの右側の部分に新しい文章を作成するためのボタンが表示されます。Wordではいろんな定型文章の雛形(テンプレートと呼びます)が用意されており、テンプレートを使うと定型文章を簡単に入力することができます。テンプレートを使うには「標準のテンプレート」をクリックして表示されるパネルの中から選択します。テンプレートを使わずに、白紙の文章を新規作成する場合は、新規の「白紙の文書」をクリックして下さい。新規作成を行うとその文章を編集するための新しいWordウィンドウが開かれます。このように、Wordでは一つの文章に対して一つのウィンドウを開くことで、同時に複数の文章を編集することが可能です。

·          ファイルを開く

 既に作成されたWordのファイルを編集するには、そのファイルのアイコンをダブルクリックするか、Wordのメニューの「ファイル」「開く」でファイルを選択します。

·          ファイルを閉じる

文章の編集が終了した場合、ウィンドウの「×」ボタンを押すか、メニューの「ファイル」「閉じる」を実行することで、その文章の編集を終了させることができます。この時、編集中の文章が変更されていた場合は、ファイルに保存するかどうかをパネルで聞いてくるので保存したい場合は「はい」を選択して下さい。

Wordのウィンドウを同時に複数開いた場合、コンピュータの動作が遅くなる可能性がありますので、必要のないWordウィンドウは閉じることをお勧めします。なお、ファイルを閉じても編集中のWord文章が一つでも残っている限り、Wordのアプリケーションは終了しません。Wordを終了させるにはメニューの「ファイル」「終了」を実行して下さい。これによって編集中のすべての文章のウィンドウが閉じられWordが終了します。

·          保存とバックアップ

編集中の文章をファイルに保存するには、メニューの「ファイル」「上書き保存」又は「ファイル」「名前を付けて保存」を実行します。前者はその文章が格納されていたファイルにデータを上書きし、後者は新しいファイルに文書を保存します。

コンピュータは何らかの原因によって時々突然動かなくなってしまう(この状態をコンピュータがハングアップしたと呼びます)ことがあります。そのような場合、それまでに編集していた文章はディスクに保存されていないので無駄になってしまいます。これを防ぐに為に、Wordに限らずコンピュータでデータを編集する場合はこまめに(数10分に一回くらいの頻度で)手動で保存することをお勧めします。また、ハードディスク内のファイルが壊れてしまう可能性もありますので、時々ファイルをフロッピーディスクやCD−Rなどにコピーしてバックアップ(backup)を取る事をお勧めします。

·          印刷

作成した文章を紙に印刷するにはメニューの「ファイル」「印刷」を実行します。パネルが表示されるので、印刷範囲や、印刷部数を指定してOKボタンを押してください。プリンタの「プロパティ」と表示されたボタンをクリックすることで、印刷の用紙のサイズ、印刷方向、一枚の紙に何ページ印刷するかなどの詳細設定を行うこともできます。

印刷を行ったときにどのような内容が印刷されるかを知るにはメニューの「ファイル」「印刷のプレビュー」を実行して下さい。ツールバーの%の部分を変更することで表示の倍率を変えることができます。印刷ミスは紙資源の無駄になりますので、印刷前にはこのプレビューを使って印刷内容が正しいかどうかを確認することをお勧めします。

4.      Word文章の編集

Wordには文章を編集するための様々な便利な機能があります。その中でよく使う便利な機能について解説します。

·          カットアンドペースト

他のWindowsアプリケーションと全く同じ方法(メニューの「編集」やCtrl-Cなどのショートカット)で文章をカットアンドペーストすることができます。

·          取り消し

メニューの「編集」「取り消し」またはショートカットのCtrl-Zによって一つ前の操作を取り消すことができます。Wordの場合、過去の操作を複数覚えていますので、取り消しを複数回実行することで過去の操作を順番に取り消すことができます。

·          検索と置換

 入力した文章の中から特定の文字列を検索することができます。検索を行うには、メニューの「編集」「検索」を実行し、表示されるパネルの中に検索したい文字を入力して「次を検索」ボタンを押してください。入力した文字がみつかるとその文字が選択状態になります。また、文章の中の特定の文字列を別の文字列に置換することができます。置換を行うにはメニューの「編集」「置換」を実行し、パネルの検索する文字列の中に置換したい文字列、置換後の文字列に置換後の文字列を入力します。次に、「次を検索」ボタンを押して置換したい文字列を探してください。見つかった文字列が選択状態になるので、その文字列を置換したい場合は「置換」ボタンを、置換せずに次を検索したい場合は「次を検索」ボタンを押してください。また、一気に該当するすべての文字を置換したい場合は「すべて置換」ボタンを押してください。

 

 

練習:下記の文書を入力して、以下の作業を行って下さい。

明日の東京の天気は晴れ、大阪の天気は雨、札幌の天気は雨のち曇りでしょう。

Ø         「天気」という文字をすべて検索して下さい。

Ø         置換を使って、「雨」を「晴れ」に置換して下さい。

Ø         再び置換を使って、元の文章に戻してください。

·          スペルチェック機能

Wordには英語や日本語のチェックを自動的に行ってくれる機能があります。例えば

  Thas are a pem

と入力してみて下さい。Thaspemの下に赤い波線が表示されるはずです。これはその部分の単語の綴りが間違っている可能性があるという事を意味します。メニューの「ツール」「文章校正」を実行すると文書内の間違っている可能性のある部分と修正候補を順番にパネルで表示してくれます。上記の文章を校正するとスペルミスだけではなく文法チェック(are→isの間違いの指摘など)もしてくれますので、文章を書いた場合は文章校正を利用ことでミスを減らすことができます。

·          ハイパーリンク

 Wordの文章中に http://www.hosei.ac.jp のようにURIを記述するとその部分が下線つきの青い文字で表示されます。この部分をクリックすることでウェブブラウザが起動し、そのURIのウェブページを見ることができます。ハイパーリンクを解除するには、ハイパーリンクの最後にカーソルを移動し、Back Spaceキーを押してください。

5.      課題

次のページの文章をできるだけ忠実に入力し、印刷して下さい。また、できた文章を保存し、メールに添付してsigesada@edu.i.hosei.ac.jpに送って下さい。

なおこの文章は法政大学のウェブページ(http://www.hosei.ac.jp/new/ga-pr030501.html)から抜粋した文章です。また、日本語のフォントは「MS明朝」、英数字のフォントは「Times New Roman」を使っています。(注:現在、該当ページの情報は更新されていますが、箇条書きの部分が最新のページにはなかったので、課題では古いページの内容のままにしてあります。最新の情報を知りたい方は上記のページを見て下さい。)

 

質問のメールなどは、sigesada@edu.i.hosei.ac.jpまでお願いします。

授業の資料の最新版はhttp://www.edu.i.hosei.ac.jp/~sigesada/にあります。
緊急・重要

2003年5月17日

法政大学

 

重症急性呼吸症候群(SARS)に関する緊急連絡(5月15日更新)

 

法政大学学生・教職員の皆さん

重度急性呼吸症候群(SARS: Severe Acute Respiratory Syndrome)についてはすでに報道等で承知されているとおりですが、法政大学では、WHOが伝播確認地域としている地域に留学中または留学・渡航を計画している皆さんに対して下記のように対応するよう勧告します。SARSの原因・伝播方法・治療方法等についてはまだ不明なことが多く、WHO・外務省等のサイト(後掲)にて最新情報を各自で収集して慎重に行動して下さい。

また、下記地域に現在留学(派遣留学・認定海外留学・休学留学等)をしているすべての学生・教職員の皆さんは、直ちに所属学部・大学院に電話・メールで現住所・連絡先を報告して下さい。

 

1.        外務省の「危険情報発出地域」に対応する法政大学からの勧告

外務省海外安全ホームページ(http://www/pubanzen.mofa.go.jp)

外務省による危険情報(4段階)の発出地域に滞在し、又は渡航計画を計画している皆さんに対応する法政大学としての勧告内容を掲載します。充分慎重な判断をして行動して下さい。

<注意:情報は日々更新されていますので上記サイトにて最新情報を確認して下さい>

 

外務省「危険情報発出レベル」と法政大学よりの勧告

 

·           十分注意して下さい
渡航を自粛、あるいは帰国について検討してください。

·           渡航の是非を検討して下さい
渡航の中止、滞在者に関しては帰国を強く勧めます。

·           渡航の延期をおすすめします
渡航を中止し、滞在者は直ちに帰国をして下さい。

·           退避を勧告します
渡航を中止し、滞在者は直ちに帰国をして下さい。